Vulnerabilities in Formidable Forms, Duplicator and Yoast SEO Plugins
Vulnerabilities have been reported in the Formidable Forms, Duplicator and Yoast SEO WordPress plugins. The Premium version of Wordfence protects against all of these vulnerabilities, even if you have not updated your plugins yet. We do recommend that you update immediately, whether or not you are using the Premium version of Wordfence.
The details of the vulnerabilities are as follows:
Formidable Forms 2.05.02 and older has multiple severe vulnerabilities
Jouko Pynnönen disclosed multiple vulnerabilities in Formidable Forms version 2.05.02 and older. The report included multiple serious problems:
- A preview function allowed unauthenticated users to execute an arbitrary shortcode. Normally, the use of shortcodes is restricted to site authors or administrators, as many of them could be used to exploit a site.
- One of the plugin’s shortcodes included a SQL injection vulnerability.
- Another shortcode allowed an unauthenticated user to view form responses.
- Form previews were vulnerable to reflected cross site scripting.
- Form input was not sufficiently sanitized to prevent stored cross site scripting, which could have been used to target administrators when they viewed form responses.
Formidable Forms is used by over 200,000 active sites according to WordPress.org. The Formidable Forms team has released multiple updates addressing these issues, starting at 2.05.02. We released a firewall rule today, protecting Wordfence Premium customers from attempts to exploit this vulnerability. Free users should upgrade to version 2.05.05 immediately.
Duplicator 1.2.28 and older vulnerable to stored XSS
WPVulnDB also reports that the Duplicator, running on over 1 million active sites, fixed a stored cross site scripting vulnerability affecting versions 1.2.28 and older. This report also included the code changes.
Duplicator version 1.2.29 fixed this issue, but their changelog does not mention a vulnerability (there is no currently entry at all for version 1.2.29). Wordfence includes built-in protection against attacks of this nature, so both Premium and free users should be safe.
Yoast SEO 5.7.1 and older vulnerable to unauthenticated XSS
Ryan Dewhurst’s WPVulnDB is reporting that Yoast SEO fixed an unauthenticated cross site scripting vulnerability that affected versions 5.7.1 and older. The code change showing the fix is linked to from the WPVulnDB report.
Wordfence also protects against this exploit (both free and Premium).
We encourage you to share these vulnerabilities with the larger WordPress community to help keep site owners safe from exploitation.
The post Vulnerabilities in Formidable Forms, Duplicator and Yoast SEO Plugins appeared first on Wordfence.